Skip to content


Configurando a placa de som padrão no GNU/Linux (Debian)

Comprei uma placa de som Creative Sound Blaster Audigy SE, porém não consegui desabilitar no SETUP minha placa onboad. Devido a isso, tive que alterar a placa de som padrão no meu sistema.

Segui configurei pelo próprio KDE:

  • Como eu utilizo o KDE 4.0, inicialmente eu configurei a placa de som inicial pelas Configurações de Sistema->Multimídia. Assim, o Phonon escolheria a placa da Creative.
    Porém, não foi o suficiente, pois alguns programas que não utilizavam o phonon ainda utilizavam a placa da via.

O jeito foi resolver a mão, pela configuração manual do ALSA:

  • inicialmente obtive a lista das placas instaladas pelo comando:
    # cat /proc/asound/cards
    
     0 [Intel          ]: HDA-Intel - HDA Intel
     HDA Intel at 0xfcffc000 irq 21
     1 [CA0106         ]: CA0106 - CA0106
     Audigy SE [SB0570] at 0xec00 irq 16
    
  • depois, verifiquei os módulos utilizados:
    # cat /proc/asound/modules
    
    0 snd_hda_intel
    1 snd_ca0106
  • agora, eu adicionei algumas linhas em ” /etc/modprobe.d/alsa-base.conf ” para orientar o “carregamento” dos módulos:
    # Determinando a placa padrão:
    options snd_ca0106 index=0
    # Determinando a segunda placa como a placa intel:
    alias snd-card-1 snd-hda-intel
    options snd-hda-intel index=1
    
  • logo após, reiniciei o computador para não ter que descarregar e carregar os módulos de som a mão… heheh

Bom… isso resolveu o problema 100%

Mais informações em: https://wiki.archlinux.org/index.php/Advanced_Linux_Sound_Architecture

Abraços

Postado em 🐧 GNU/Linux 🐧.


Uma Resposta

Fique por dentro da conversa, assine o Feed deste post   em RSS.

  1. Genésio Guimarães says

    Valeu Jeiks! Ótima dica. Ma ajudou muito. Desde que instalei o debian 6 que ele deixou como padrão a placa de som Onboard. Com a sua dica consegui inverter a situação, deixando a placa de som Offboard como padrão. Obrigado!



Some HTML is OK

ou, responda este post através de um trackback.